How do I set the tty name associated with a physical port?
Let's say you wanted to make a tty on the s1 port and call it rs0000 and a tty on the s2 port and call it rs0001.
You could run:
mkdev -c tty -s rs232 -t tty -l rs0000 -p sa0 -w s1 # creates rs0000
and
mkdev -c tty -s rs232 -t tty -l rs0001 -p sa1 -w s2 # creates rs0001
How do I use mksysb to clone a system?
I use the following steps on the master machine to clone an AIX system:
1) Remove the password from root.
2) Remove the NIS line from the end of the /etc/group file (the last
line with the +: )
3) Change most of the level '2' designations in /etc/inittab to level
'3' to prevent them from being started up when the new system is
booted (the minimum ones to change are rc.nfs and rc.tcpip)
4) Boot in service mode and change the name and ip address to a "spare"
set to avoid address collision.
5) Clear /tmp, /usr/tmp and /usr/spool/lpd/stat.
6) Run mkszfile and edit it to be sure /usr is as small as possible;
then mksysb from the command line.
The above changes allow me to boot in normal mode the first time, get in
as root, change the above files back and do the other things necessary
to configure the new system.
Then, of course, I go back and clean up and reboot my master machine.
Note: 1 and 2 lets you log in even if you can't get on the network.
It prevents the login process from trying to reach an NIS server.
Step 2 needed only if you use NIS.
How do I remove a non-existant physical volume?
To delete a phantom disk from the ODM use reducevg with the pvid instead of the disk name. You are running some command such as lsvg or varyonvg and it is griping about a disk that is no longer findable right? In that warning message, it should give you a pvid. Try one of the following, (note: reducevg updates the VGDA but not the ODM).
reducevg -f
ldeletepv -g VGid -p PVid
-g Required, specify the VGid of the volume group you are
removing the physical volume from
-p Required, specify the PVid of the PV to be removed
How do I kill a process that ignores kill -QUIT -KILL -STOP
If there is i/o pending in a device driver, and the driver does not catch the signal, you can't kill it - a reboot is the only way to clear it.
Furthermore, if the process stays hung for more than a few minutes, you can find out what device is wedged by doing this --
% echo trace -k $(expr / 256) | crash | tee stack
How can I see "console" messages?
Use the swcons command to redirect the console to a file. Or use chcons to do it permanently.
How do I merge my /etc/password and /etc/security/password for Crack?
/usr/sbin/mrgpwd. You must have permissions to read /etc/security/password.
I lost the root password, what should I do?
Boot from boot diskettes, bootable tape, or bootable CD.
At the Installation/Maint menu select item 4, "Start a limited function
maintenance shell.
At the subsequent "#" prompt enter the command:
getrootfs hdiskN
(where "N" is replaced by the number of a disk on your system
that is in rootvg.)
That will run for about a minute or so and you get a # prompt back. At this
point you are logged in as root in single user mode.
Change to /etc/security and edit the passwd file. Delete the three lines
under root: password, update time (or whatever it's called), and
flags. Save the file.
Then at the prompt, give root a new password.
Shutdown/reboot in normal mode. Log in with new password.
No comments:
Post a Comment