AIX Interview Questions
How would I know if I am running a 32-bit kernel or 64-bit kernel?
To display if the kernel is 32-bit enabled or 64-bit enabled, type:
How do I know if I am running a uniprocessor kernel or a multiprocessor kernel?
/unix is a symbolic link to the booted kernel. To find out what kernel mode is running, enter ls -l /unix and see what file /unix it links to. The following are the three possible outputs from the ls -l /unix command and their corresponding kernels:
/unix -> /usr/lib/boot/unix_up # 32 bit uniprocessor kernel
/unix -> /usr/lib/boot/unix_mp # 32 bit multiprocessor kernel
/unix -> /usr/lib/boot/unix_64 # 64 bit multiprocessor kernel
|
Note:
AIX 5L Version 5.3 does not support a uniprocessor kernel.
How can I change from one kernel mode to another?
During the installation process, one of the kernels, appropriate for the AIX version and the hardware in operation, is enabled by default. Let us use the method from the previous question and assume the 32-bit kernel is enabled. Let us also assume that you want to boot it up in the 64-bit kernel mode. This can be done by executing the following commands in sequence:
ln -sf /usr/lib/boot/unix_64 /unix
ln -sf /usr/lib/boot/unix_64 /usr/lib/boot/unix
bosboot -ad /dev/hdiskxx
shutdown –r
|
The /dev/hdiskxx directory is where the boot logical volume /dev/hd5 is located. To find out what xx is in hdiskxx, run the following command:
Note:
In AIX 5.2, the 32-bit kernel is installed by default. In AIX 5.3, the 64-bit kernel is installed on 64-bit hardware and the 32-bit kernel is installed on 32-bit hardware by default.
How would I know if my machine is capable of running AIX 5L Version 5.3?
AIX 5L Version 5.3 runs on all currently supported CHRP (Common Hardware Reference Platform)-based POWER hardware.
How would I know if my machine is CHRP-based?
Run the prtconf command. If it's a CHRP machine, the string chrp appears on the Model Architecture line.
How would I know if my System p machine (hardware) is 32-bit or 64-bit?
To display if the hardware is 32-bit or 64-bit, type:
How much real memory does my machine have?
To display real memory in kilobytes (KB), type one of the following:
lsattr -El sys0 -a realmem
|
Can my machine run the 64-bit kernel?
64-bit hardware is required to run the 64-bit kernel.
What are the values of attributes for devices in my system?
To list the current values of the attributes for the tape device, rmt0, type:
To list the default values of the attributes for the tape device, rmt0, type:
To list the possible values of the login attribute for the TTY device, tty0, type:
lsattr -l tty0 -a login –R
|
To display system level attributes, type:
How many processors does my system have?
To display the number of processors on your system, type:
How many hard disks does my system have and which ones are in use?
To display the number of hard disks on your system, type:
How do I list information about a specific physical volume?
To find details about hdisk1, for example, run the following command:
How do I get a detailed configuration of my system?
Type the following:
The following options provide specific information:
-p
|
Displays platform-specific device information. The flag is applicable to AIX 4.2.1 or later.
|
-v
|
Displays the VPD (Vital Product Database) found in the customized VPD object class.
|
For example, to display details about the tape drive, rmt0, type:
You can obtain very similar information by running the prtconf command.
How do I find out the chip type, system name, node name, model number, and so forth?
The uname command provides details about your system.
uname -p
|
Displays the chip type of the system. For example, PowerPC.
|
uname -r
|
Displays the release number of the operating system.
|
uname -s
|
Displays the system name. For example, AIX.
|
uname -n
|
Displays the name of the node.
|
uname -a
|
Displays the system name, nodename, version, machine ID.
|
uname -M
|
Displays the system model name. For example, IBM, 9114-275.
|
uname -v
|
Displays the operating system version.
|
uname -m
|
Displays the machine ID number of the hardware running the system.
|
uname -u
|
Displays the system ID number.
|
What version, release, and maintenance level of AIX is running on my system?
Type one of the following:
How can I determine which fileset updates are missing from a particular AIX level?
To determine which fileset updates are missing from 5300-04, for example, run the following command:
What SP (Service Pack) is installed on my system?
To see which SP is currently installed on the system, run the oslevel -s command. Sample output for an AIX 5L Version 5.3 system, with TL4, and SP2 installed would be:
Is a CSP (Concluding Service Pack) installed on my system?
To see if a CSP is currently installed on the system, run the oslevel -s command. Sample output for an AIX 5L Version 5.3 system, with TL3, and CSP installed would be:
How do I create a file system?
The following command will create, within volume group testvg, a jfs file system of 10MB with mounting point /fs1:
crfs -v jfs -g testvg -a size=10M -m /fs1
|
The following command will create, within volume group testvg, a jfs2 file system of 10MB with mounting point /fs2 and having read only permissions:
crfs -v jfs2 -g testvg -a size=10M -p ro -m /fs2
|
How do I change the size of a file system?
To increase the /usr file system size by 1000000 512-byte blocks, type:
chfs -a size=+1000000 /usr
|
Note:
In AIX 5.3, the size of a JFS2 file system can be shrunk as well.
How do I mount a CD?
Type the following:
mount -V cdrfs -o ro /dev/cd0 /cdrom
|
How do I mount a file system?
The following command will mount file system /dev/fslv02 on the /test directory:
How do I mount all default file systems (all standard file systems in the /etc/filesystems file marked by the mount=true attribute)?
The following command will mount all such file systems:
How do I unmount a file system?
Type the following command to unmount /test file system:
How do I display mounted file systems?
Type the following command to display information about all currently mounted file systems:
How do I remove a file system?
Type the following command to remove the /test file system:
How can I defragment a file system?
The defragfs command can be used to improve or report the status of contiguous space within a file system. For example, to defragment the file system /home, use the following command:
Which fileset contains a particular binary?
To show bos.acct contains /usr/bin/vmstat, type:
Or to show bos.perf.tools contains /usr/bin/svmon, type:
How do I display information about installed filesets on my system?
Type the following:
How do I determine if all filesets of maintenance levels are installed on my system?
Type the following:
How do I determine if a fix is installed on my system?
To determine if IY24043 is installed, type:
How do I install an individual fix by APAR?
To install APAR IY73748 from /dev/cd0, for example, enter the command:
instfix -k IY73748 -d /dev/cd0
|
How do I verify if filesets have required prerequisites and are completely installed?
To show which filesets need to be installed or corrected, type:
How do I get a dump of the header of the loader section and the symbol entries in symbolic representation?
Type the following:
How do I determine the amount of paging space allocated and in use?
Type the following:
How do I increase a paging space?
You can use the chps -s command to dynamically increase the size of a paging space. For example, if you want to increase the size of hd6 with 3 logical partitions, you issue the following command:
How do I reduce a paging space?
You can use the chps -d command to dynamically reduce the size of a paging space. For example, if you want to decrease the size of hd6 with four logical partitions, you issue the following command:
How would I know if my system is capable of using Simultaneous Multi-threading (SMT)?
Your system is capable of SMT if it's a POWER5-based system running AIX 5L Version 5.3.
How would I know if SMT is enabled for my system?
If you run the smtctl command without any options, it tells you if it's enabled or not.
Is SMT supported for the 32-bit kernel?
Yes, SMT is supported for both 32-bit and 64-bit kernel.
How do I enable or disable SMT?
You can enable or disable SMT by running the smtctl command. The following is the syntax:
smtctl [ -m off | on [ -w boot | now]]
|
The following options are available:
-m off
|
Sets SMT mode to disabled.
|
-m on
|
Sets SMT mode to enabled.
|
-w boot
|
Makes the SMT mode change effective on next and subsequent reboots if you run the bosboot command before the next system reboot.
|
-w now
|
Makes the SMT mode change immediately but will not persist across reboot.
|
If neither the -w boot or the -w now options are specified, then the mode change is made immediately. It persists across subsequent reboots if you run the bosboot command before the next system reboot.
How do I get partition-specific information and statistics?
The lparstat command provides a report of partition information and utilization statistics. This command also provides a display of Hypervisor information.
How do I know if my volume group is normal, big, or scalable?
Run the lsvg command on the volume group and look at the value for MAX PVs. The value is 32 for normal, 128 for big, and 1024 for scalable volume group.
How to create a volume group?
Use the following command, where s partition_size sets the number of megabytes (MB) in each physical partition where the partition_size is expressed in units of MB from 1 through 1024. (It's 1 through 131072 for AIX 5.3.) The partition_size variable must be equal to a power of 2 (for example: 1, 2, 4, 8). The default value for standard and big volume groups is the lowest value to remain within the limitation of 1016 physical partitions per physical volume. The default value for scalable volume groups is the lowest value to accommodate 2040 physical partitions per physical volume.
mkvg -y name_of_volume_group -s partition_size list_of_hard_disks
|
How can I change the characteristics of a volume group?
You use the following command to change the characteristics of a volume group:
How do I create a logical volume?
Type the following:
mklv -y name_of_logical_volume name_of_volume_group number_of_partition
|
How do I increase the size of a logical volume?
To increase the size of the logical volume represented by the lv05 directory by three logical partitions, for example, type:
How do I display all logical volumes that are part of a volume group (for example, rootvg)?
You can display all logical volumes that are part of rootvg by typing the following command:
How do I list information about logical volumes?
Run the following command to display information about the logical volume lv1:
How do I remove a logical volume?
You can remove the logical volume lv7 by running the following command:
The rmlv command removes only the logical volume, but does not remove other entities, such as file systems or paging spaces that were using the logical volume.
How do I mirror a logical volume?
1. mklvcopy LogicalVolumeName Numberofcopies
2. syncvg VolumeGroupName
How do I remove a copy of a logical volume?
You can use the rmlvcopy command to remove copies of logical partitions of a logical volume. To reduce the number of copies of each logical partition belonging to logical volume testlv, enter:
Each logical partition in the logical volume now has at most two physical partitions.
Queries about volume groups
To show volume groups in the system, type:
To show all the characteristics of rootvg, type:
To show disks used by rootvg, type:
How to add a disk to a volume group?
Type the following:
extendvg VolumeGroupName hdisk0 hdisk1 ... hdiskn
|
How do I find out what the maximum supported logical track group (LTG) size of my hard disk?
You can use the lquerypv command with the -M flag. The output gives the LTG size in KB. For instance, the LTG size for hdisk0 in the following example is 256 KB.
/usr/sbin/lquerypv -M hdisk0
256
|
You can also run the lspv command on the hard disk and look at the value for MAX REQUEST.
What does syncvg command do?
The syncvg command is used to synchronize stale physical partitions. It accepts names of logical volumes, physical volumes, or volume groups as parameters.
For example, to synchronize the physical partitions located on physical volumes hdisk6 and hdisk7, use:
To synchronize all physical partitions from volume group testvg, use:
How do I replace a disk?
1. extendvg VolumeGroupName hdisk_new
2. migratepv hdisk_bad hdisk_new
3. reducevg -d VolumeGroupName hdisk_bad
How can I clone (make a copy of ) the rootvg?
You can run the alt_disk_copy command to copy the current rootvg to an alternate disk. The following example shows how to clone the rootvg to hdisk1.
How can I display or set values for network parameters?
The no command sets or displays current or next boot values for network tuning parameters.
How do I get the IP address of my machine?
Type one of the following:
ifconfig -a
host Fully_Qualified_Host_Name
|
For example, type host cyclop.austin.ibm.com.
How do I identify the network interfaces on my server?
Either of the following two commands will display the network interfaces:
To get information about one specific network interface, for example, tr0, run the command:
How do I activate a network interface?
To activate the network interface tr0, run the command:
How do I deactivate a network interface?
For example, to deactivate the network interface tr0, run the command:
1. How do you create an LV?
Ans: #mklv –y lv_name vg_name PPs pv_name
2. How do you create a filesystem on a given LV?
Ans: # crfs –v jfs –d /dev/lv_name –m /mount_point
3. What is Journaled File System?
Ans: It maintains a log in corresponding log device before committing any changes to LV and thus maintains integrity of file system.
4. What are the types of filesystems in AIX?
Ans: JFS, JFS2, CDRFS, NFS
5. What are the differences between JFS and JFS2 FS?
Ans: JFS- inode allocation while creating file systems is static
JFS2 – Inode allocation is dynamic
JFS- maximum file system size is 1 TB
JFS2- Maximum file system size is 4 PB
JFS- Inode size is 128 Bytes
JFS2 – Inode size is 512 bytes
6. What is the file responsible to tell about the filesystems?
Ans: /etc/filesystems
7. How will you troubleshoot the file system problem?
Ans: using fsck and logform
8. Where you keep the shared folders in AIX?
Ans: /etc/exports
9. What exportfs –a command does?
Ans: It reads entries from /etc/exports and updates /etc/xtab
10. What is inode?
Ans: It is an Index node and points to the another inode or a datablock
11. What is superblock?
Ans: First block of any file system and contains Meta data of its like no of inodes and free list of inodes etc.
12. What is the daemon responsible for error log?
Ans: errdemon
13. What is the path for default log file?
Ans: /var/adm/ras/errorlog
14. How do you restrict remote user?
Ans: chuser rlogin=false user_name
15. How do you list filesystems?
Ans: lsfs
16. What are the stanzas in /etc/filesystem?
Ans: dev=, Mount=, Log=, Vfs=, Check=, Type=
17. How do you check error log?
Ans: # errpt -a
18. What is /proc file system?
Ans: contains process related information of all processes which are presently running.
19. What is the command to change the password of another user by a user –admin (other than root user) who can set the passwords for users?
Ans: pwdadm
20. In the above question user “admin” belongs to which group?
Ans. Security
21. How will you set the password for a user whose password length must be eight characters?
Ans: smit chuser or # chuser minlen=8 user_name Entries will be updated in /etc/security/user
22. Where is the password for a user stores?
Ans: /etc/security/passwd
23. What are the fields available in the: /etc/security/passwd file?
Ans: last update, password and flag
24. What are the fields available in /etc/passwd file?
Ans: username: password indication: uid: gid: gcos: homedirectory: shell
25. What are the actions will take happen while exporting vg?
Ans: Removes that vg entry from odm
Removes corresponding filesystem entries related to VG from /etc/filesystems.
26. One VG is exported from a system and imported in another system there created some new filesystems in that VG. Now to import that VG back to the old system what command you should execute?
ANS: importvg –L –y vgname pvname
27. What is the VGDA information?
Ans: VG id, LV names, PV count, total PP’s, free PP’s, lv count, LTG etc.
(Use # lqueryvg –p hdiskx –At)
28. While importing VG the /etc/filsystems will get updated, from where the information of file systems it gets?
Ans: LVCB of each lv (mount point information will reside in LVCB if the mount point length is less than 128 characters)
29. How will you set the customized UMASK for all users?
Ans: Add the entry in /etc/security/user- In default Section
30. What is LVM and its components? What is the advantage of LVM in AIX.?
Ans: VG, PV, LV, FILESYSTEMS, File systems can be extended beyond the limit of PV size to multiple PVs.
31. Can we add PV of different sizes into an existing VG? How to fully utilize the hdd space?
Ans Yes we can add PV of different sizes to existing VG. Change t factor
32. How you find out the characteristics of VG? What are the main features you look for?
Ans: #lsvg vgname. NO. PPs, Free PPs, stale PPs etc
33. What is stale partition?
Ans: When a pp is out of synchronization it shows as stale partition.
34. How many PPs can be pointed by a LP? Is the size of LP increases with mirroring of PPs?
Ans: 3 PPs can be pointed a LP. No the size of LP does not increase with PP mirroring
35. What are the information you get in VGDA ?
Ans: PP size, PV count, max PPs, LV names etc, Free PPs,
36. What is the difference between VGDA & VGSA?
Ans:
37. What is LVCB?
Lvname, no of copies, inter policy, intra policy, no. of lps, lvid etc
38. What is quorum? Give details.
Ans: 51% of total VGDA information is called quorum
39. What is ‘t’ factor?
Ans: by t factor we can increase max no. of PPs from default 1016. Ex: t2 will make 2032 max physical partitions.
40. How you make concurrent VG ?
Ans: mkvg –C –y vgname pvname
41. What are daemons in NFS ? Give details of each daemon ?
Ans : nfsd, rpc.mountd, rpc.statd, rpc.lockd and at client side biod
42. When we reopen an exported file after working on it we get stale error. What is the reason ?
43. What is the difference between network interface and network devices?
Ans: interface is logical device for tcpip networking, network devices are physical adapter.
44. How to add IP by aliasing to a network device ?
Ans: ifconfig en0 193.9.200.227 255.255.255.0 alias
45. What is netmask ?
Ans: to differentiate between network address and host address.
46. Give an example of class B network
Ans: 130.10.200.0
47. What is loopback address and its utility ?
Ans: IP address 127.0.0.1 is called loopback address and is used by the node to check the functioning of its own tcpip sevices.
48. Where to add gateway in the network ? Can we use router as gateway ?
Ans: to connect between two different networks. Yes we can use router as gateway.
49. What is the difference between /etc/passwd and /etc/security/passwd ?
Ans: user information are stored in /etc/passwd . encrypted passwd is stored /etc/security/passwd
50. How to disable the lock of a user when he has crossed the failed login limits? Which is the file to look into it?
Ans: chuser account_locked=true user. /etc/security/user
51. What is the difference between systemwide profile and .profile of an user ?
Ans: ./profile of user overrides the env variables set by /etc/profile
52. What difference you find in #su root and #su – root ?
Ans: Su – root initializes the environment to that of root.
53. What is umask and why we require it ?
Ans: The umask value is deducted from default permission value 777 of a file when created.
54. What is tcb and how it works ?
Ans: trusted computing base. When it is enable only trusted commands are executed by verifying with /etc/security/sysck.cfg.
55. What is quota and give full syntax of commands.
Ans: it fixes the limits for files and sizes for each user. Quota
56. What is trusted path and trusted shell?
Ans:
57. How you enable ACL in a file.
Ans: extended permission to be set in file. To set use the command acledit,aclget,aclput
58. How to find out the characteristics of an user ? What is difference between #lsuser and #lsattr?
Ans: lsuser, by lsattr we can find out the attributes of a device
59. What is the procedure to configure remote printer?
Ans: enable lpd daemon, create a queue and connect it to remote queue
60. What is difference between defined and available state in ODM ?
Ans: defined means it is already configured but not available for use. Available means the device is ready for use.
61. How you see maintenance level in AIX? What is the other command than #oslevel –r
Ans: instfix
62. How you install ML in AIX?
Ans: #smitty update_all
63. What is the procedure in installing a package in AIX ? What is applied , commited, rejected states ?
Ans: applied –for testing of package only, committed: to install the package into the system. Reject: to reject the package if it fails in applied state
64. Can we install ML5 and ML6 simultaneously in applied state in same machine?
Ans: yes we can
65. If we remove ML5 from the m/c, will the ML6 will work ?
Ans: yes it will work
66. What is difference between backup and archive ?
Ans: archive: the backup data stored permanently for retrieval later date. Backup is a regular process like full backup, differential backup, incremental backup.
67. What is the difference between incremental and differential backup ?
Ans: In diff. Bacup it is compared with last full backup. In incremental backup it is compared to last backup.
68. What is crontab and how to schedule a job to run at 5pm on every Saturday?
Ans: to schedule to run a process at particular time. Edit the crontab file by crontab –e or crotab –l > crontmp, edit the crontmp by syntax m, h, day of month, month, day of week /process. Then start the process by crontab crontmp
69. What is the location where cron queues are being maintained
Ans: /var/spool/cron/crontabs
70. Where errorlog files are stored ?
Ans: /var/adm/ras/errlog
71. When there is a problen in a system what to do first ?
Ans: lookinto error log by errpt –a command
72. What is difference between errorlog and alog files ?
Ans: alog gives the information on boot error.
73. What is the boot sequence in AIX and give the details of each step of booting.
Ans:
74. What is mksysb backup? What are advantages we get out of it?
Ans: rootvg backup, sytem can be restored in case of failure, PP size can be changed, filesystem size can be reduced by shrink
75. Can we do the mksysb backup and savevg of other vg on same tape? Give the reason.
Ans: No
76. What is the procedure to retrieve only /etc/hosts file from mksysb tape? Give commands with exact syntax.
Ans: #tctl –f /dev/rmt0 rewind
#restore –s4 –xqvf /dev/rmt0.1 ./etc/hosts
77. How you increase the size of a file system by 5GB? Give command details.
Ans: #chfs –a size=+5G /data
78. What are the tools available for performance monitoring?
Ans: sar, vmstat, topas
79. When you tell the system is CPU Bound or memory bound?
Ans: Run the sar command. If the value of %USER + %SYS is more than 80% we call the system is CPU bound. Run the vmstat command. If PI and PO is high we call the system to be memory bound.
80. How will you check a given file system is large filesystem enabled?
Ans: lsfs –q fsname, if bf=true the given filesystem supports big filsystem
81. What is command to see MAC address of NIC
Ans: # lscfg –l ent0 –v
82. How will you check the serial no of the system?
Ans: uname –a
83. How will you see the parent device for en0?
Ans: # odmget –q “name like en0” CuDv
84. What is the fastpath for SSA RAID?
Ans. # smit ssaraid
85. How will you check the given hdiskn has how many no of Pdisks of your SSA box?
Ans: # ssaexlate –l hdiskn
86. What is the command to list all supported hardware by your system?
Ans: lsdev –P –H
87. How will you list the total no adapters your system have?
Ans: lsdev –Cc adapter
88. What is the command to see your dumpdevice?
Ans: sysdumpdev –l
89. What is the default dumpdevice?
Ans: /dev/hd6
90. List the file system hd1, hd2 etc and what they are meant for?
Ans:
91. How will you see the hard ware errors?
Ans: # errpt –d –H
92. How to clear the all errorlog messages?
Ans:# errclear 0
93. How to make the secondary dumpdevice permanently active?
Ans: # sysdumdev –P –s /dev/xxx.
94. Tell me the steps to replace the one hdd belongs to the mirrored rootvg?
Ans. Explain the detailed procedure
95. What is the command to move an lv to another hdd?
Ans: # migratepv –l lv_name hdiskx hdisky
96. How to disable a user from remote login?
Ans: # chuser rlogin=false user_name
97. How to prevent all users to login from the remote?
Ans: # touch /etc/nologin (Except root all users can not login from remote)
98. How to add a pv into a VG?
Ans: # extendvg vg_name pv_name
99. How to see the ftp service is running or not? How to enable it?
Ans: lssrc –s inetd, startsrc –s inetd or startsrc –t ftpd
100. What are the differences between IPAT over IP aliasing and replacement?
Ans: Explained the complete details of both methods.
101. What is the difference between MOUNT=TRUE and MOUNT=AUTOMATIC in /etc/filesystems?
Ans: OS related File systems which are mounted at the time of boot process will have ‘AUTOMATIC’ attribute and other filesystem which can be mounted along with system startup
Will have ‘TRUE’ attribute.
102. What is sticky bit and tell me example?
Ans: Sticky bit permission will be set to directory so as all user can make use of the files in that directory, but only owner can delete the file.
103. What is setuid and tell me example?
Ans: A file which is having SUID will be excuted as if its effective id Eg. /etc/passwd
104. If T and S permissions are set for the files what does it mean?
Ans: When Sticky bit and SUID permission set on directory and file which are not with executable permissions set respectively will shown like this.
105. How to check a VG is mirrored or not?
Ans: If a lp is mapped to more than one pp by lsvg –l vgname command then VG is said to be mirrored.
106. What are the differences between AIX 5.1 and 5.3?
Ans:
107. What is the difference between UDP and TCP?
Ans:TCP- Connection oriented and acknowledgment for packet transmitted.
UDP-User Datagram protocol- Connectionless and no acknowledgment for the packets transmitted.
108. How to restore a single file of rootvg from mksysb backup tape media?
Ans: restore –S4 xvf /dev/rmt0 ./
109. How to format a log file system?
Ans: logform
110. What is the difference between applied and committed s/w?
Ans: applied state software can be rejected if don’t work properly if it suite then it can be committed. A software which was committed can‘t be rejected only way is uninstall.
111. How to commit applied state software?
Ans: installp –cgX
112. What is the difference between hard and soft mount in NFS?
Ans: For Hard mount the client keep tries to mount the file system until it succeeds. Where as the Soft Mount tries to mount the file system for few attempts if it is not succeeded in a given attempts it gives up.
113. What is the command to make the hdisk as bootable (bosboot)?
Ans: bosboot –ad /dev/hd5.
114. What is the lpp resource in NIM?
Ans. It has software image to be installed at client.
115. How to list all file systems?
Ans: lsfs
116. How will you edit the crontab?
Ans: crontab –e
crontab –l > filename, edit file and crontab filename.
117. How do you list all volume groups?
Ans. Lsvg
118. How do you mirror rootvg?
Ans. Extendvg rootvg hdiskn, mirrorvg rootvg hdiskn, bosboot –ad, bootlist –m normal hdiskx, hdiskn.
119. What are the commands you used for performance monitoring?
Ans. Vmstat, sar, iostat, topas etc.
120. How will you come to know the system required more real memory using vmstat?
Ans. If pi and Po count is more (if paging activity is more even though it has enough paging space)
121. What is the use of AT command and how will you list the jobs?
Ans: One time operation for a given time. Atq –L
122. How do you exclude some file systems while taking mksysb backup?
Ans: By mentioning the file systems name in exclude.rootvg
123. How do you list the pv in system?
Ans: lspv
124. What are the AIX installation methods?
Ans: Complete and overwrite, preservation installation and migration
125. What are the prerequisites before attempting migration installation?
Ans: Take the system backup, check for hardware and s/w compatibility for newly installable os. Prepare with remedies for known problems.
126. How to roll back to the previous ML level if the newly installed ML had problem with applications.
Ans: If newly installed ML is in applied state, reject it. If it is committed state remove the fix and reinstall the previous ML.
127. What are the difference between applied state and committed state?
Ans: If we select applied state it will not replace the previous level and will have option to commit or reject the newly installed s/w. In committed state newly installed s/w will overwrite the existing s/w and will not have option to reject.
128. What is /etc/filesystems and what is its role?
Ans: /etc/filesystem has information regarding file systems, its mount point type of file system etc. Its main purpose to mount and check the file systems as per the parameters mentioned in it.
129. How to see the paging space?
Ans: lsps –a
130. How to increase the paging space?
Ans: chps –s pp’s devicename.
131. What is the default paging space device?
Ans: hd6
132. What is ODM & Location of Database Files
Ans; ODM is database which contains the information of devices & system configuration. /etc/objrepos, /usr/lib/objrepos, /usr/share/lib/objrepos
133. Give details of each database files.
Ans: /etc/objrepos: contains customized database
/usr/lib/objrepos: contains predefined database
/usr/share/lib/objrepos: contains software vital product data
134. How to set password history?
Ans: /etc/security/user
135. How to set two or three password?
136. What happens when execute exportvg & importvg?
Ans: Exportvg: removes info. of particular VG from ODM
Importvg: Add info. Of from VGDA of disk to ODM
137. What is NFS & file names of NFS?
NFS is distributed file system which provide remote access of file system.
File name: /etc/exports
138. How to set permissions for exported directory?
Using /etc/exports
139. What are the types of Installation in AIX?
Ans: Complete/Overwrite Migration and Preservation Installation.
140. What is migration installation?
Ans: For Upgrading the version of AIX.
141. Can we preserve /var file system in preservation installation?
Ans: By default it removes /var files system. However by specifying in /etc/preserve.list we can retain the /var filesystem .
142. If you confirmed rootvg is completely crashed and no backup is available what are the actions to be performed?
Ans: Reinstall OS, apply the required ML level and install /configure all apllications. Import all volume groups.
143. How to create a user using command prompt by specific home directory:
Ans: #mkuser -a /xxxx/user1 user1
144. What is zombie process?
Ans: It is dead process but it shows in the process list
145. What are LVM components?
Ans: Explained all components like PPs, LPs, etc.
146. What is command to create LV
Ans: # mklv -t type -y lv_name vg_name no.of PPs pvname
147. How to create a Vg:
Ans: mkvg -y vgname pvname1 pvanme2
148. What is the path for sulog?
Ans: /var/adm/sulog
149. What is path for wtmp?
Ans: /var/adm/wtmp
150. What is the path for failedlogin?
Ans /etc/security/failedlogin
151. What makes difference when you su with - and without - ?
ANs: With - env variable will set for newly switched user.
152. What are env variables?
Ans: PATH, TZ, PWD, SHELL, EDITOR, etc.
153. What component we can not install once installation is carried out?
Ans: TCB
154. How will you check whether TCB is installed or not?
Ans: /usr/bin/tcbck
155. How will you list applied S/W?
Ans: lslpp -l | gerp apllied
156. What is difference between applied state and committed state installation?
ANs Applied state - Can be committed of rejected
Committed state- Can not be rejected.
157. What is the difference between backup and archive?
Ans: Backup: Performs regularly and recycle the media periodically.
Archive: For preserving data for longer times and media should have good quality for preserving data and less seek time is required for data retrieval on need basis.
158. How to kill a process?
Ans: By confirming the process whether it controlled by SRC or Init, if it is init use kill command of if it is by SRC use stopsrc.
159. What is shell?
Ans Command intrepeter.
160. How to check ML version?
Ans: # oslevel -r
161. If the system had ML version 7 and rootvg is courrpted and needs to restore mksysb. But mksysb backup was taken with ML5 How to go about?
Ans: Restore mksysb and update new ML version with 7.
162. What is stickybit can we set it for file?
Ans: To prevent deletion of each other files of users who had common directory?
Stickybit set for a file is no use.
163. What is the purpose of chmod
Ans To assign file/directory permissions for user/group/others
164. How will you check the attributes of a user?
Ans: lsuser
165. How will you prevent user form logging remote?
ANs # chuser -a rlogin=false username
166. If the uptime file is corrupted how will you see the server uptime?
Ans: # who -b
167. What is the difference between differential and incremental backup?
Ans: Differential backup will take the backup of the data modified w.r.t to its previous full backup whereas incremental backup will take the backup of modified data w.r.t its previous backup.
168. How do you add pv in shared vg?
Ans. Explain detailed procedure.
169. What is the significance of 9 with kill command?
Ans: It surly kills the process and will not save any
170. How will you list the specific attributes of a user?
Ans: lsuser -a id home username
171. How will u see the version and ML of AIX?
Ans: oslevel –r for version and instfix –ik |grep ML for ML
172. How will u check the errors during booting?
Ans: alog command
173. How will u check the errors after booting?
Ans: errpt command
174. Detailed information about NFS?
Ans: Explain about NFS and the daemons at server and client
175. What is LVM?
Ans. Logical Volume manager- explained its advantages and all of its components.
176. What is the parameter used for inodes while creating filesystem?
Ans: nbpi
177. Explain the installation procedure for installing AIX
Ans. Explained the complete installation procedure and narrated type os installation
178. How to repair a file system?
Ans. Fsck and logform
179. What is super block?
Ans: First block of every file system which contains meta data of the file system and its alternate block is 31.