AIX Basic Interview Questions
1. How will you list the users who are currently logged in?
Ans: who, finger, f
2. How will you get the login and log out time?
Ans: last
3. What are the fields in /etc/passwd?
Ans: Uname,Password Attribute,User ID,Group ID,Gecos,Home Directory,Login Shell
4. What is * and ! Symbols indicate in /etc/passwd fields?
Ans: * indicates that account is not activated,! Indicates that passwd has been assigned and the account is activated.
5. How can u change the shell for the particular user?
Ans: $HOME/.profile
6. How can u change the root shell prompt?
Ans: ps1=”shell_name”
7. How to make a PV available?
Ans: chdev -l hdisk2 -a pv=yes
8. How to list lv's in rootvg, what is the output of opened/syncd, closed/syncd and open/stale?
Ans: lsvg -l rootvg, Indicates the LV state for the lv's. Open/stale indicates the logical volumes is opened but contains partitions that are not current. Opened/syncd opened and synchronized. Closed/syncd not opened and synchronized.
9. Tell about Performance Monitoring?
Ans: topas, svmon, vmstat, iostat, netstat, sar ,entstat, lvmstat, lparstat, lpstat.
10. How can we get the Network Statistics?
Ans: netstat. ifconfig
11. How can u get the OS name?
Ans: uname
12. How can u get the OS Version?
Ans: uname -v
13. How to list the Paging Space?
Ans: lsps -a
14. What is meant by Patches?
Ans: Its a fix for the problems that are encounter currently. Eg: APAR
15. What is the difference between inittab and crontab?
Ans: inittab is used for System Initialization and crontab is used for Scheduling.
16. Tell about boot process?
Ans: POST, System ROS, Software ROS, Kernel Initialization, 3 phases of booting.
17. What is the role of cfgmgr in boot devices?
Ans: It configures base devices and non-base devices.
18. How to refresh the inittab?
Ans: It automatically refresh for every 60 seconds.
19. How to check the maintenance level and technology level?
Ans: oslevel -r
20. How to increase File System size?
Ans: chfs -a size=+10 -m /doli
21. How to go the end of the file in vi Editor?
Ans: shift+g (caps G)
22. What is ODM?
Ans: ODM is a repository which stores the operating system related information such as interfaces, softwares, tcpip configuration.
23. What is mirrorvg?
Ans: mirrorvg command is used to mirror data from one PV to another PV in the same VG.
24. What are the Components of LVM?
Ans: Volume Group, Physical Volume, Physical Partition, Logical Volume, Logical partition.
25. How to check the available size of the PV in VG and migration of PV?
Ans: lspv hdisk0, migratepv sourcepv destinationpv eg: migratepv hdisk0 hdisk1
26. What is the use of Telinit?
Ans: It is used to set the runlevel.
27. Which command to list active vg?
Ans: lsvg -o
28. How to view the run level?
Ans: who -r, cat /etc/.init.state
29. How will u create the user?
Ans: mkuser username, mkuser -a username (for admin)
30. What are the changes will occur while creating a user?
Ans: /etc/security/user, etc/security/limits, /etc/security/environ, etc/passwd.
31. How will you specify the big vg?
Ans: mkvg -B -y vgname -s 128 hdisk0
32. How will u view the modified time of a file?
Ans: ls -lt
33. What is quorum?
Ans: It is used to maintain the data integrity of a particular vg. Used for retrieving data.
35. How will u change the runlevel?
Ans: Telinit.
36. What is page in and page out?
Ans: Page in: Moving the process or data from the real memory to the virtual memory in the hard disk.
Page out: Moving the process or data from the virtual memory to the real memory.
38. How will u list the active users?
Ans: who
39. Who -r
displays the run level and who -b last system start up time.
40. What is the use of tar command?
Ans: It is used to copy and retrieve files into the archive and out of the archives.
42. How to monitor the file growth?
Ans: By impleming the quota using quotaon command.
43. What is quota and how to work with quota?
Ans: It is an effective way to control the use of disk space. Using quotaon command we can enable the quota for a particular file system or for a particular user.
Eg: 1. chfs -a “quota=userquota” /home
quotaon -u /usr/Tivoli/tsm/server/db
44. How to increase or decrease the quota?
Ans:Using edquota command.
45. In which phase /etc/inittab is used?
Ans: Third phase
How to view the real memory size?
Ans: bootinfo -r, prtconf -m
What are the daemons for the Nfs?
Ans:rpc.mountd, biod, nfsd, rpc.statd, rpc.lockd.
What is the cron daemon?
Ans: It is a power scheduler and a long running background process which is used to execute a job periodically.
50. What is the use of “i” flag in mksysb command?
Ans: i flag is for ./image file which is used to collect the information about the filesystems, logical volumes, mount point of the rootvg which is being backed.
How to change the 32 bit kernel to 64 bit kernel?
Ans: # ln -sf /usr/lib/boot/unix_64
# ln -sf /usr/lib/boot/unix_64 /usr/lib/boot/unix
# bosboot -ad /dev/ipldevice
52. What is the use of uname -v and oslevel command?
Ans: To find the version of the os we are using uname -v and to see the version. Release.modification.fix we are using oslevel command.
53. What is zombie process?
Ans: It is a dead process that is no longer executing but still recognized in process table. It is also known as defunct.
How to display the files of size larger than 50MB in /usr?
Ans: find /usr -size 50M -print.
55. Cpu performance monitoring command?
Ans: Topas, Sar
56. How to increase the size of the file system?
Ans: chfs -a size = +10M -m/doli
57. How to give write permission for the file which has been mounted?
Ans: While using the mount command specify the rw permission.
58. How to get help if there is no man page?
Ans: Smit can be used.
59. How to increase the paging space?
Ans: chps command
How to troubleshoot if the system is too slow?
Ans: Kill the unwanted process which consumes the cpu resources using ps command.
What is the output for iostat?
Ans: cpu statistics, i/o statistics of entire system, disks, tapes and file systems.
62. What is the use of mkuser, lsuser and how to list the groups?
Ans: mkuser command is used to create normal user accout or admin, lsuser lists the user account attributes and to list the group use the command lsgroup.
63. What is use of extendlv command?
Ans: it is used to add the logical partitions to the existing Logical volume.
64. How to extend the user space quota?
Ans: edquota command can be used to extend the user space.
65. What is the last step in booting process?
Ans: LED displays are turned off and the init process will continue to the next command in the /etc/inintab.
66. How to list the logical volumes?
Ans: lslv
67. What is the use of skulker command?
Ans: To delete the temporary files in the file systems.
68. Tell me about the AIX installation steps?
Ans:
69. How will you create the file systems?
Ans: crfs -v type of file systems -g rootvg -a size =10M -m /fs1
70. Difference between crontab and init tab?
Ans: Crontab is used to schedule the jobs and init tab will contain the entry for the commands that has to be executed.
71. Can we create a filesystem directly?
Ans: File systems can also be without creating LV.
72.Types of file systems?
Ans: jfs, jfs2, cdrfs, nfs
73.Difference b/w at and crontab?
Crontab u can schedule lot of process for any time.But using at command only one process to be schedule.at is an temporary but crontab for permanent process.
74. What is the command to list the pv?
Ans: lspv
75. What are all the pv state?
Ans: active, missing, removed.
76. What is the crontab and how will u do scheduling?
Ans: Cron tab is used for scheduling the jobs and for scheduling we can use crontab -e command.
77. If the size of the file system is not able to change? Troubleshoot the issue?
Ans: May be the quota is turned on for that file system.
78. How will u mirror the Logical volume?
Ans: Using mklvcopy command.
81. What is SUID, SGID, sticky bit?
Ans: SUID is used to set user id for a particular file so that, that particular can access that file. It is inheriting the power of the super user.
SGID: SGID is used to set the group id so that every one in the group can access that file.
Sticky bit: Sticky bit is an access right flag used to set permissions for the so that no other user can rename or delete that file.
82. Quorum
Ans : The minimum number of nodes that must be running in order for the GPFS daemon to start.
Mirroring vg
Ans : # mirrorvg vgname
Difference between JFS and JFS2
Function |
JFS |
JFS2 |
Architectural maximum file system size |
1 TB |
4 PB |
Architectural maximum file size |
64 GB |
4 PB |
Number of i-nodes |
Fixed |
Dynamic |
Inode size |
128 bytes |
512 bytes |
Fragment size |
512 |
512 |
Block size |
4096 |
4096 |
Directory organization |
Linear |
B-tree |
Compression |
Yes |
No |
Default ownership at creation |
sys.sys |
root.system |
SGID of default file mode |
SGID=on |
SGID=off |
Quotas |
Yes |
Yes |
No comments:
Post a Comment