Journaled file System
Two type supported by AIX
-
JFS : Journaled File System
-
JFS2 : Enhanced JFS
Journaling :
-
Before writing the actual data, a journaling file system logs the metadata to a circular JFS log on disk.
-
In the event of an OS crash, journaling retores consistencu by processing the information in the JFS log file.
JFS
-
Original AIX file system
-
Developed for transaction-oriented, high performance Power system
-
Both scaleable and robust
-
Logging feature available.
-
Its recoverable file system which means that even if the system crash, no fle system transaction will be in an inconsistence state.
JFS2
-
Default file system on AIX since version 5.3
-
Filesystem can be dynamically increased and decreased.
-
Data encryption
-
Both internal and external logging available
-
Support Snapshot.
-
Support for larger enable filesystem
-
Minium Size of JFS2 file is 16MB
Steps involve in making FS
-
Create a file system on volume group using crfs command
-
mount it on directory ( In order to activate that file system)
*** Each time we do any FS command, an entry is made in /etc/filesystems file
Command related to File system
Most important file system :
/etc/filesystems
-
Creating a JFS2 file system :
-
The crfs creates a file system on a logical volume within a previously created volume group. We can also use smit crfs_j2 for same operation.
-
A new logical volume is created for the filessystem and a entry is made into /etc/filesystems.
-
The Options include:
-
-v : Filesystem type ( Example: jfs2)
-
-m : mount point
-
-A : mount automatically on reboot or not
-
-p : Mount as ro/rw
-
-l : size of log volume in case of jfs
-
-g : volume group name
-
-d : logical volume group name
-
-a : size of file system
-
Example: Creating a file system without mentioning a Logical Volume name
-
crfs -v jfs2 -g rootvg -a size=16M -m /data
By default a
logical volume name : fslv02 is created
We have to mount
the FS over the mount point in order to user the FS
-
Example: Creating a file system by mentioning a logical volume name
-
crfs -v jfs2 -d datalv1 -a size=20M -m /data
-
Changing the size of File system:
- We can increase (+), decrease(-) the size of File system by using chfs command with -a size options
- The minium size you can decrease by is 16M
- Example: Increaing the File System : chfs -a size=+21M /data
-
Example: Decreaing the size of file sytem : chfs -a size=-128M /data
-
Removing the JFS2 file system
-
The file system must first be unmounted.
-
We can remove the FS by using smitty rmfs2 or rmfs
-
Options for rmfs command are :
-
-r : Remove the mountpoint of the system
-
-i : Display warning and prompt the user to remove the file system
No comments:
Post a Comment