Tanti Technology

My photo
Bangalore, karnataka, India
Multi-platform UNIX systems consultant and administrator in mutualized and virtualized environments I have 4.5+ years experience in AIX system Administration field. This site will be helpful for system administrator in their day to day activities.Your comments on posts are welcome.This blog is all about IBM AIX Unix flavour. This blog will be used by System admins who will be using AIX in their work life. It can also be used for those newbies who want to get certifications in AIX Administration. This blog will be updated frequently to help the system admins and other new learners. DISCLAIMER: Please note that blog owner takes no responsibility of any kind for any type of data loss or damage by trying any of the command/method mentioned in this blog. You may use the commands/method/scripts on your own responsibility. If you find something useful, a comment would be appreciated to let other viewers also know that the solution/method work(ed) for you.

Thursday 21 November 2013

VIOS FAQ

Initialize the LPAR Configuration :
#mkgencfg -o init
[OS] Software Management :
To display VIO Server level:
# ioslevel
To update the IOS software:
updateios –dev /update -
To installs a new filesets (mainly used for TL updates):
updateios –dev /cd0 -install -accept
To commit all applied :
updateios –commit
To rejects all uncommitted updates :
updateios –reject
To clean all incomplete pieces of the preVIOus installation :
updateios –clean
To remove a fileset :
updateios –remove fileset_name
To take the OS backup in a CD ROM :
# backupios –cd /dev/cd1 -cdformat
To take the OS backup in a DVD-RAM :
# backupios –cd /dev/cd1 -udf
To take the OS backup in a tape drive :
# backupios –tape /dev/rmt0
Just verifies the backup available in a tape :
# backupios –tape /dev/rmt0 -verify
Generates backup to a file. No user VGs are -nosvg back’d up :
# backupios –file /opt/file1
To display the underlying AIX OS version :
oem_platform_level
To open a non-restricted root shell :
oem_setup_env
This shell is used mainly for the installation of vendor software such as device drivers.
Remote Management :
To enable remote_management using NIM master :
remote_management nim1
To disable remote management :
remote_management –disable
License Management:
To display the current license :
license –view
To accept the license :
license –accept
To view if the license has been accepted :
license
Software Management:
To list all the installed software :
license
To list all the installed software and their history
license –hist
Management of Virtual Terminals:
To open a virtual terminal for partition with id 2 :
# mkvt –id
To close a virtual terminal for a partition with id 2 :
# rmvt –id 2
Device Management:
To change the attribute of a device permanently.
# chdev -dev scsi0 -attr -perm
Sometimes it reboots the system if perm is used
To disable the path between hdisk1 and scsi0 :
# chpath -dev hdisk1 -pdev scsi0 -op disable
To configures the devices in the VIO server :
# cfgdev
To configures the devices attached to scsi0 adapter :
# cfgdev –dev
To unconfigure the cd-rom device :
# rmdev –dev cd0
To unconfigure scsi adapter and its child devices :
# rmdev –recursive –dev scsi1
To unconfigures the children of pci1 but not the PCI bus pci1 :
# rmdev –pdev pci1
Management of Virtual/Shared Devices:
To create a virtual target device that maps lv20 as a virtual disk for a client partition hosted by the vhost0 virtual server adapter :
# mkvdev -vdev lv20 -vadapter vhost0
Same as above except here hdisk is used instead of a logical volume :
# mkvdev -vdev hdisk6 -vadapter vhost2
To create a SEA that maps the physical Ethernet adapter ent4 as a virtual adapter for the client
partitions served by the virtual Ethernet adapters ent6 and ent7, using ent6 as the default adapter and 8 as the default id :
# mkvdev -sea ent4 -vadapter ent6,ent7 -default ent6 -defaultid 8
To remove a virtual target device vtscsi9 along with its backing lv :
rmvdev –vdev vtscsi9 –
To remove all virtual target device associated with backing device lv001 :
rmvdev –vdev lv001
To remove a specific virtual target device :
rmvdev –vtd vtscsi10
List Device Mapping:
To list all virtual target devices and backing devices mapped to virtual server adapter vhost2 :
lsmap -vadapter vhost2
To list SEA and physical device mapped to virtual Ethernet Adapter ent4 :
lsmap -vadapter ent4 –net
To list all virtual target devices and backing devices where backing devices are of type LV :
lsmap -all -type lv
To list all network mapping :
lsmap –all –net
How to list Devices :
To display all the devices :
lsdev
To display all the virtual devices :
lsdev –virtual
To display all the virtual adapters :
lsdev –type adapter –virtual
To display all the slots :
lsdev –slot s
To display all the adapters :
lsdev –type adapter
Few other device types: disk, lv, optical, tape, tty
To list all physical Ethernet adapters and Etherchannel available for creating a SEA :
lsdev –type ent4sea
To list all virtual Ethernet adapters available for creating a SEA :
lsdev –type ven4sea
To list all adapters over which ip address can be configured :
lsdev –type ent4ip
To display parent device of a device :
lsdev –dev hdisk0 –
To list disks names and physical location alone :
lsdev -type disk -field name physloc
Logical Volume Manager :
Volume Group
To create a vg on hdisk1 :
# mkvg -vg newvg hdisk1
To drain I/O’s for a vg and suspends future I/O’s :
# chvg -suspend vg03
To resume normal I/O operations for a vg :
# chvg -resume vg03
Unlock a VG if left in a locked state by abnormal termination of another lvm operation :
# chvg -unlock vg03
To add a physical volume to a volume group :
# extendvg vg3 hdisk3
To remove a PV from a VG :
# reducevg vg01 hdisk1
To remove a PV and all residing LVs from a VG with no confirmation :
# reducevg –rmlv –f vg01
To activate a vg :
# activatevg vg03
To deactivate a vg :
# deactivatevg vg03
To mirror the VIO Server’s rootvg to hdisk4 and reboots VIO Server :
# mirrorios –force hdisk4
To mirror the VIO Server’s rootvg to hdisk4 but don’t reboot the server :
# mirrorios –defer hdisk4
To remove the rootvg mirror from hdisk4 :
# unmirrorios hdisk4
To import a VG from hdisk07 :
# importvg –vg vg001 hdisk07
To export a VG :
# exportvg vg3
Note: Volume Group containing a paging space can’t be exported
To sync a VG :
# syncvg –vg vg01
To sync a LV :
# syncvg –lv lv001
To sync a PV :
# syncvg –pv hdisk4 hdisk5
To redefine a VG based on the VGDA from hdisk04 :
# redefvg –dev hdisk04
Logical Volume :
To create a logical volume of size 1MB in vg01 :
 mklv  –lv lv001 vg01 1M hdisk1
To create a logical volume with mirror in place in vg01 of size 1GB :
 mklv  –mirror vg01 1G
To extend an LV by 3MB :
# extendlv lv01 3M
To extend an LV by 1GB with space taken from hdisk5 :
# extendlv lv01 1G hdisk5
To remove a logical volume :
# rmlv lv05
To display the properties of a logical volume :
# lslv lv03
To display info about LV by Physical volume :
# lslv –pv lv03
To display LVs that can be used as backing devices :
# lslv –free
To make a copy for lv01 in hdisk03 :
 mklv copy lv01 hdisk03
To remove lv01’s copy from hdisk03 :
# rmlvcopy lv01 hdisk03
To copy the contents of lv01 to lv02 :
# cplv lv01 lv02
To copy the contents of lv01 to a new lv in vg01 :
# cplv –vg vg01 lv01
To change the name of oldlv to newlv :
# chlv –lv newlv oldlv
Physical Volume
To display all physical volumes in the system :
# lspv
To display the status and characteristics of hdisk03 :
# lspv hdisk03
To list all the available PVs used as virtual SCSI backing devices :
# lspv –avail
To list PVs that can be used as virtual SCSI backing devices and are not currently a backing device :
# lspv –free
To move physical partitions from hdisk1 to hdisk2 :
# migratepv hdisk1 hdisk2
To move physical partitions in lv01 from hdisk1 to hdisk2 :
# migratepv –lv lv01 hdisk1 hdisk2
Storage Pool Management:
To create storage pool “client_data” using hdisk3 hdisk4 hdisk3 and hdisk4 :
# mksp -f client_data
To set client_data storage pool as default :
# chsp –default client_data
To list all storage pools :
# lssp
To list the default storage pool :
# lssp –default
To list the backing device in rootvg storage pool :
# lssp –bd –sp rootvg
To attach a storage from a storage pool to a Virtual SCSI adapter:
# mkbdsp -bd lv001 -vadapter vthost2 -tn vtscsi9
To removes storage from a Virtual SCSI adapter, and removes the backing device :
# rmbdsp –bd lv001
To remove storage from a Virtual SCSI adapter, And makes sure backing device is not deleted :
# rmbdsp –bd lv001 -savebd
To removes storage from a Virtual SCSI adapter, and removes the backing device :
# rmbdsp –vtd vtscsi9
To removes storage from a Virtual SCSI adapter. and makes sure backing device is not deleted :
# rmbdsp –vtd vtscsi8 -savebd
Network Configuration :
TCP/IP Configation:
To configure tcpip on a network interface :
# mktcpip -hostname sys01VIO2 -inetaddr 9.47.90.113 -interface en2 -netmask 255.255.255.0 -gateway 9.47.90.1 -nsrvdomain yahoo.com -start
-
To display the stored tcp/ip configuration in the system :
# lstcpip –stored
To display ethernet adapters on the system :
# lstcpip –adapters
To display the system hostname :
# lstcpip –hostname
To display DNS name servers in search order and domain name :
# lstcpip –namesrv
To display the routing table :
# lstcpip –routtable
To display routing table in numeric output instead of hostname :
# lsctpip –num –routtable
To display all the open inet sockets :
# lstcpip –sockets –family inet
To display the status of all configured interfaces :
# lstcpip –state
To remove all TCP/IP configuration :
# rmtcpip –all
To unconfigure tcpip in en0:
# rmtcpip –interface en0
To cleanup static routing table :
# rmtcpip –f -routing
To remove IP information from en0 after reboot :
# rmtcpip –f –interface en0 -nextboot
To remove DNS information and clears the hosts file :
# rmcpip –namesrv
Managing IP address-to-host name Mapping Entries:
To add IP address-to-host name mapping entry :
 hostmap -addr 192.100.1.7 -host alpha
To list all IP address-to-host name mapping entries :
 hostmap –ls
To delete the IP address-to-host name mapping entry :
 hostmap-rm 192.100.1.7
Managing Network Services:
To enable all the network services :
 startnetsvc ALL
To enable the telnet daemon :
 startnetsvc telnet
To enable the ftp daemon :
 startnetsvc ftp
To enable the ssh daemon :
 startnetsvc ssh
To enable the ldap daemon :
 startnetsvc ldap
To enable the cimserver daemon :
 startnetsvc cimserver
To enable the xntpd daemon :
 startnetsvc xntpd
To send CLI tracing details to the system log :
 startnetsvc tracelog
To send system error to the system log :
 startnetsvc errorlog
To disable all the network services :
 stopnetsvc  ALL
To disable the telnet daemon :
 stopnetsvc  telnet
To disable the ftp daemon :
 stopnetsvc  ftp
To disable the ssh daemon :
 stopnetsvc  ssh
To disable the ldap daemon :
 stopnetsvc  ldap
To disable the cimserver daemon :
 stopnetsvc  cimserver
To disable the xntpd daemon :
 stopnetsvc  xntpd
To stop sending CLI tracing details to system log :
 stopnetsvc  tracelog
To stop sending system error log to the system log :
 stopnetsvc  errorlog -
To display the status of ftp network service :
# lsnetsvc ftp
Managing DNS, Domain and Search Order Entries:
To add a domain entry :
# cfgnamesrv -add -dname abc.aus.century.com
To add a name server entry :
# cfgnamesrv –add -ipaddr 192.9.201.1
To display all the DNS entries :
# cfgnamesrv -ls
Network Tuning Parameters:
To display the maximum size of the mbuf pool :
# optimizenet –get thewall
To set a machine as internet work router over TCP/IP networks :
# optimizenet –set ipforwarding=1
To display information on udp_recvspace :
# optimizenet –h udp_recvspace
Network Monitoring:
To display all the statistics, including the device- specific statistics :
# entstat ent0
To reset all the statistics back to their initial values :
# entstat –reset ent0
To display the route to a particular host :
# traceroute nis.nsf.net
System Monitoring :
To display the summary of current system activity :
# sysstat
To display the system statistics :
# topas
System Management Commands:
To halt the operating system :
shutdown
To halt the operating system forcibly :
shutdown –force
To reboot the VIO server :
shutdown –restart
To invalidate the boot list for service mode :
bootlist -mode service –rm
To display the boot list for service mode :
bootlist -mode service –ls
To set the boot list for normal mode :
bootlist –more normal hdisk0
To display the complete detailed error report :
errlog –ls
To remove all the error log entries :
errlog –rm 0
To remove the error log entries older than 5 days :
errlog –rm 5
To change the system date and time :
# chdate -day 12 -month 10 -year 2004 -hour 16 -minute 30
To change the language for the entire system to French Canadian :
# chlang -lang fr_CA
To display available languages :
# chlang –ls
To perform hardware problem determination and maintenance :
# diagmenu
To generate report on microcode levels of all the devices :
# invscout –report
To display the vpd survey of the partition :
# invscout –vpd
To append the current MOTD [Message Of The Day] :
# motd –append “Message”
To overwrite MOTD :
# motd –overwrite -file filename
To do the initial configuration of VIO Server :
# cfgassist
It is like configuration assitant in AIX.
To do filesystem scan :
# fsck /dev/lv01
To display exported (nfs) directories on a remote server :
# showmount hostname
To start system dump on the primary device :
# startsysdump
To display continuous disk report on disk1 at 2sec interval :
VIOstat -disk disk1 2
To display adapter throughput reports :
VIOstat –adapter
To display system and adapter throughput reports :
VIOstat –sys –adapter
To gather system info and to store it in the floppy disk :
# snap -general -dev /dev/rfd0
To display microcode levels of all devices :
# lsfware –all
Managing Agents:
To start an agent : # startsvc agent_name
To stop an agent: # stopsvc agent_name
To display an agent’s configuration information :
# lssvc agent_name
To display all the available agents :
# lssvc
To display the attributes associated with ITSM_base agent :
# cfgsvc –ls ITM_base
To display the ITM_base agent ssh public key :
# cfgsvc -key ITM_base
User Management:
To create a user :
# mkuser
To change an attribute of a user :
# chuser
To display the properties of a user :
# lsuser
To remove a user from the system :
# rmuser
To set/reset password for a user :
# passwd
Security Commands:
To display all failed logins :
# lsfailedlogin
To display the contents of global command log :
# lsgcl
To displays high system settings :
VIOsecure -level high
To apply all of the high system settings to the system :
VIOsecure -level high –apply
To displays the current system settings :
VIOsecure –view
To allow IP activity on the ftp-data, ftp, ssh, www, https, rmc, and cimon ports, and to deny other IP activity :
VIOsecure –firewall on
To enable IP activity on all ports :
VIOsecure –firewall off
To display the list of allowed ports :
VIOsecure -firewall view
Redundancy configuration using virtual fibre channel adapters
Redundancy configurations help protect your network from physical adapter failures as well as Virtual I/O Server failures.
With N_Port ID Virtualization (NPIV), you can configure the managed system so that multiple logical partitions can access independent physical storage through the same physical fibre channel adapter. Each virtual fibre channel adapter is identified by a unique worldwide port name (WWPN), which means that you can connect each virtual fibre channel adapter to independent physical storage on a SAN.
Similar to virtual SCSI redundancy, virtual fibre channel redundancy can be achieved using Multi-path I/O (MPIO) and mirroring at the client partition. The difference between traditional redundancy with SCSI adapters and the NPIV technology using virtual fibre channel adapters, is that the redundancy occurs on the client, because only the client recognizes the disk. The Virtual I/O Server is essentially just a pipe. The second example below uses multiple Virtual I/O Server logical partitions to add redundancy at the Virtual I/O Server level as well.
Example: Host bus adapter failover
This example uses Host bus adapter (HBA) failover to provide a basic level of redundancy for the client logical partition. The figure shows the following connections:
    • The storage area network (SAN) connects physical storage to two physical fibre channel adapters located on the managed system.
    • The physical fibre channel adapters are assigned to the Virtual I/O Server and support NPIV.
    • The physical fibre channel ports are each connected to a virtual fibre channel adapter on the Virtual I/O Server. The two virtual fibre channel adapters on the Virtual I/O Server are connected to ports on two different physical fibre channel adapters in order to provide redundancy for the physical adapters.
    • Each virtual fibre channel adapter on the Virtual I/O Server is connected to one virtual fibre channel adapter on a client logical partition. Each virtual fibre channel adapter on each client logical partition receives a pair of unique WWPNs. The client logical partition uses one WWPN to log into the SAN at any given time. The other WWPN is used when you move the client logical partition to another managed system.
The virtual fibre channel adapters always has a one-to-one relationship between the client logical partitions and the virtual fibre channel adapters on the Virtual I/O Server logical partition. That is, each virtual fibre channel adapter that is assigned to a client logical partition must connect to only one virtual fibre channel adapter on the Virtual I/O Server, and each virtual fibre channel on the Virtual I/O Server must connect to only one virtual fibre channel adapter on a client logical partition.
Host bus adapter failover
The client can write to the physical storage through client virtual fibre channel adapter 1 or 2. If a physical fibre channel adapter fails, the client uses the alternative path. This example does not show redundancy in the physical storage, but rather assumes it would be built into the SAN.
Note: It is recommended that you configure virtual fibre channel adapters from multiple logical partitions to the same HBA, or you configure virtual fibre channel adapters from the same logical partition to different HBAs.
Example: HBA and Virtual I/O Server failover
This example uses HBA and Virtual I/O Server failover to provide a more advanced level of redundancy for the client logical partition. The figure shows the following connections:
    • The storage area network (SAN) connects physical storage to two physical fibre channel adapters located on the managed system.
    • There are two Virtual I/O Server logical partitions to provide redundancy at the Virtual I/O Server level.
    • The physical fibre channel adapters are assigned to their respective Virtual I/O Server and support NPIV.
    • The physical fibre channel ports are each connected to a virtual fibre channel adapter on the Virtual I/O Server. The two virtual fibre channel adapters on the Virtual I/O Server are connected to ports on two different physical fibre channel adapters in order to provide redundancy for the physical adapters. A single adapter could have multiple ports.
    • Each virtual fibre channel adapter on the Virtual I/O Server is connected to one virtual fibre channel adapter on a client logical partition. Each virtual fibre channel adapter on each client logical partition receives a pair of unique WWPNs. The client logical partition uses one WWPN to log into the SAN at any given time. The other WWPN is used when you move the client logical partition to another managed system.
HBA and Virtual I/O Server failover
The client can write to the physical storage through virtual fibre channel adapter 1 or 2 on the client logical partition through VIOS 2. The client can also write to physical storage through virtual fibre channel adapter 3 or 4 on the client logical partition through VIOS 1. If a physical fibre channel adapter fails on VIOS 1, the client uses the other physical adapter connected to VIOS 1 or uses the paths connected through VIOS 2. If VIOS 1 fails, then the client uses the path through VIOS 2. This example does not show redundancy in the physical storage, but rather assumes it would be built into the SAN.
Considerations
These examples can become more complex as you add physical storage redundancy and multiple clients, but the concepts remain the same. Consider the following points:
    • To avoid configuring the physical fibre channel adapter to be a single point of failure for the connection between the client logical partition and its physical storage on the SAN, do not connect two virtual fibre channel adapters from the same client logical partition to the same physical fibre channel adapter. Instead, connect each virtual fibre channel adapter to a different physical fibre channel adapter.
    • Consider load balancing when mapping a virtual fibre channel adapter on the Virtual I/O Server to a physical port on the physical fiber channel adapter.
    • Consider what level of redundancy already exists in the SAN to determine whether to configure multiple physical storage units.
    • Consider using two Virtual I/O Server logical partitions. Since the Virtual I/O Server is central to communication between logical partitions and the external network, it is important to provide a level of redundancy for the Virtual I/O Server. Multiple Virtual I/O Server logical partitions require more resources as well, so you should plan accordingly.
    • NPIV technology is useful when you want to move logical partitions between servers. For example, in active Partition Mobility, if you use the redundancy configurations above, in combination with physical adapters, you can stop all the I/O activity through the dedicated, physical adapter and direct all traffic through a virtual fibre channel adapter until the logical partition is successfully moved. The dedicated physical adapter would need to be connected to the same storage as the virtual path. Since you cannot migrate a physical adapter, all I/O activity is routed through the virtual path while you move the partition. After the logical partition is moved successfully, you need to set up the dedicated path (on the destination logical partition) if you want to use the same redundancy configuration you had configured on the original logical partition. Then the I/O activity can resume through the dedicated adapter, using the virtual fibre channel adapter as a secondary path.
IOS – Information and Maintenance
 1. List all ioscli commands
help
You can type
help
to display a command’s syntax, e.g
help lsmap
Usage: lsmap {-vadapter ServerVirtualAdapter | -plc PhysicalLocationCode |
-all} [-type BackingDeviceType ... | -net]
[-field FieldName ...] [-fmt delimiter]
Displays the mapping between physical and virtual devices.
-all Displays mapping for all the server virtual adapter
devices.
-vadapter Specifies the server virtual adapter device
by device name.
-plc Specifies the server virtual adapter device
by physical location code.
-type Specifies to display virtual devices whose backing
device matches the type given.
-net Specifies supplied device is a virtual server
Ethernet adapter.
-field Specifies a list of fields to be displayed.
-fmt Divides output by a user-specified delimiter.
2. IOS Version
ioslevel
1.5.2.1-FP-11.1
3. Apply IOS Fixes
Put the IOS fixes somewhere in a local directory or on an NFS server (e.g. /mnt/iosfixes). Then run
updateios -dev /mnt/iosfixes -accept
4. Reboot the VIO Server
shutdown –restart
Virtual Devices: Storage
1. List unmapped disks
lspv -free
NAME PVID SIZE(megabytes)
hdisk24 none 8631
hdisk25 none 8631
hdisk26 none 8631
hdisk27 none 8631
Warning:
If you use vendor specific device drivers (such as the SDD or EMC drivers) you see all
hdisks as free. You have to limit the list to your logical devices, e.g.
lspv -free | grep vpath
2. List all Disk Mappings
lsmap -all
SVSA Physloc Client Partition ID
————— ——————————————– ——————
vhost1 U9117.570.65E12FB-V1-C102 0x0000000a
VTD vtscsi1
LUN 0×8100000000000000
Backing device hdisk6
Physloc U7879.001.DQDHXYN-P1-C4-T1-W50050763041302AA-L4021400000000000
VTD vtscsi8
LUN 0×8200000000000000
Backing device hdisk14
Physloc U7879.001.DQDHXYN-P1-C4-T1-W50050763041302AA-L4031400100000000
3. Create a Virtual SCSI Host Adapter
This has to done on the HMC for the profile of the VIO server: You create a new
Virtual SCSI Host-Adapter and assign it only to your client LPAVIOS Profile: Add Virtual SCSI Adapter
The same slot ID should then be assigned to a new client adapter in the client LPAR’s profile.
You can do these steps dynamically to avoid a restart of the VIO server. Use the Dynamic Logical Partitioning
option for that. If you go for the dynamic option don’t forget to do the same assignments in the profiles aswell,
otherwise your LPAR loses all storage after a new start of the VIOS!
After dynamically adding the server hostadapters you have to rerun the configuration mamager before you
can see the new vhost device:
cfgdev
4. Remove a Virtual SCSI Host Adapter
rmdev -dev vhostX [ -recursive ]
The option »-recursive« can be used to remove all still attached child devices.
Then remove the adapters dynamically from the VIO server aswell as from the VIOS’ profile.
5. Assign a Disk/LV to a Virtual SCSI Host Adapter
To map hdisk22 to vhost1 just type
$ mkvdev -vdev hdisk22 -vadapter vhost1
vtscsi19 available
The VIO server assigns the next free number (19 here) and creates the mapping device
vtscsi19. But you can specify your own name for the mapping device by making use of the
»-dev« option:
$ mkvdev -vdev hdisk22 -dev vthdisk22_barney -vadapter vhost1
vthdisk22_barney available
If you use LVs rather than whole disks or LUNs the same rules apply:
# default mapping device
$ mkvdev -vdev LPAR21_lv03 -vadapter vhost1
vtscsi19 available
custom mapping device
$ mkvdev -vdev LPAR21_lv03 -dev vtdisk21_lv03 -vadapter vhost1
vtdisk21_lv03 available
6. Unassign a Disk/LV from a Virtual SCSI Host Adapter
rmvdev -vtd vtscsiXX
Virtual Devices: Network
1. List Shared Ethernet Adapters
lsmap -all -net
SVEA Physloc
—— ——————————————–
ent12 U9117.570.65E12FB-V2-C20-T1
SEA ent13
Backing device ent3
Physloc U7311.D20.651372C-P1-C01-T2
2. Create a Shared Ethernet Adapter
To create a Shared Ethernet Adapter (SEA) you need:
    • a physical adapter as backend: 
    • a virtual adapter as defined in the VIOS’ profile: 
    • an internal VLAN ID: 
If you use the Shared Ethernet Adapter Failover capability of recent IOS releases you also need
    • a second virtual adapter as defined in the VIOS’ profile: 
for the control channel:
simple:
$ mkvdev -sea -vadapter -default -defaultid
Shared Ethernet Adapter Failover:
$ mkvdev -sea -vadapter -default -defaultid -attr ha_mode=auto ctl_chan=
Example: To create a Shared Ethernet Adapter on top of an virtual adapter ent11 using
VLAN 20, the physical adapter ent2 as backend, and the virtual adapter ent13 for the
control channel type:
$ mkvdev -sea ent2 -vadapter ent11 -default ent11 -defaultid 20 -attr ha_mode=auto ctl_chan=ent13
3. List Links on Physical Ethernet Adapters
netstat -cdlistats | grep -Ei “\(ent|media|link status”
ETHERNET STATISTICS (ent3) :
Link Status : Up
Media Speed Selected: 100 Mbps Full Duplex
Media Speed Running: 100 Mbps Full Duplex
4. Set an local IP Address
To configure an local IP 192.168.1.2 address to en0 use
mktcpip -hostname \ -inetaddr 192.168.1.2 \ -interface en0 -start \ -netmask 255.255.255.0 \ -gateway
5. Remove an local IP Address
If you want to remove the IP configuration from en0, type
rmtcpip -interface en0

No comments:

Post a Comment