Pre-Checks:
Map the disk to the client from both the vios
vioa
Check the paths
set path which was from viob to 2
Its done now ...
- Update the adapter settings:
# chdev -l fscsi0 -a fc_err_recov=fast_fail
# chdev -l fscsi0 -a dyntrk=yes
# chdev -l fscsi0 -a dyntrk=yes
- Make sure that exported Lun exported from SAN should be available in both the VIOS which is going to be mapped to client lpar through vscsi.
- Set reserve_lock to no for the disk which was added in both the vios from SAN.
Use the below commands to set it to no
#chdev -l hdisk1 -a reserve_lock=no
#chdev -l hdisk1 -a reserve_lock=no -P
#
#chdev -l hdisk1 -a reserve_lock=no -P
#
- Pre-check whether disk was by mistakenly used in any other client already
#lqueryvg -Atp hdisk1
root@vio1:/ #lqueryvg -Atp hdisk1
0516-320 lqueryvg: Physical volume hdisk1 is not
asigned to a volume group.
asigned to a volume group.
0516-066 lqueryvg: Physical volume is not a volume group member.
Check the physical volume name specified.
root@vio1:/ #
Map the disk to the client from both the vios
check the diagram
vioa
#mkvdev -vdev hdisk1 -vadapter vhost1 -dev myvio1clivtd
Viob
#mkvdev -vdev hdisk2 -vadapter vhost1 -dev myvio2clivtd
Now in client:
Run config manager
#cfgmgr
root@cli1:/ #lspv
hdisk0 0004a256f06e0c6e rootvg active
hdisk1 0004a25613b2835f datavg
hdisk2 0004a25613b287f1 datavg
hdisk3 0004a2561dc9d8bd datavg
hdisk4 0004a2561dd57f15 datavg
hdisk5 0004a2561da57f16 None
root@cli1:/ #
Check the paths
root@orange-lpar:/ #lspath -l hdisk5
Enabled hdisk5 vscsi1
Enabled hdisk5 vscsi2
Enabled hdisk5 vscsi1
Enabled hdisk5 vscsi2
Check the path priorities
# lspath -AE -l hdisk5 -p vscsi1
priority 1 Priority True
# lspath -AE -l hdisk5 -p vscsi2
priority 1 Priority True
set path which was from viob to 2
# chpath -l hdisk5 -a priority=1 -p vscsi1
# chpath -l hdisk5 -a priority=2 -p vscsi2
Its done now ...
No comments:
Post a Comment