Required Filesets:
For Server - bos.sysmgt.nim.master and bos.sysmgt.nim.spot
For Client - bos.sysmgt.nim.client
Few Resource Definitions:
SPOT - Shared Product Object Tree is a directory containing files required to boot a machine and the boot image
LPP_SOURCE - Licensed Program Product source is a directory containing images/filesets that AIX uses to load software
MKSYSB - Mksysb resource used to build a machine
Requirements for NIM Server:
Disk Space :
1. 3 GB per base lpp_source resource
2. 500 MB + per mksysb resource
3. 500 MB per SPOT resource
4. Additional buffer space for future growth
Other Requirements:
# Minimum 512 MB real memory
# 10 or 100 MBPS ethernet adapter
My Recommendations for NIM VG and Filesystems :
1. Create a seperate VG called 'nimvg' with enough space.
2. Create the following filesystems in nimvg based upon your requirement
a. /tftpboot - To hold boot images
b. /export/nim - To hold the resources like SPOT, LPP, Mksysb
Directory Structure :
/export/nim/lpp_source - To hold lpp source resources
/export/nim/spot - To hold spot resources
/export/nim/mksysb - To hold the mksysb backup for clients
Naming Schemes:
Follow the below schemes to easily identify during regular operations :
spot530TL6 - SPOT for AIX V 5.3 TL 6
spot530TL9 - SPOT for AIX V 5.3 TL 9
lpp_source530TL6 - LPP_SOURCE for AIX V 5.3 TL 6
lpp_source530TL9 - LPP_SOURCE for AIX V 5.3 TL 6
client_server1 - Mksysb image of the host server1
client_server2 - Mksysb image of the hsot server2
How to setup the NIM Master :
0. Create the /tftpboot and /export/nim file systems as per yoru requirement
1. Initial setup of NIM Master
a. ODM database
b. Boot Area: /tftpboot directory that is used to store boot files (images)
c. /etc/niminfo - Is the Key configuration file that exists on both master and clients
d. nimesis daemon - This is the daemon which used to communicate with the nim clients
2. Insert the AIX CD into the master server's CD Drive
3. Create LPP_SOURCE and SPOT resources
Commands to manage NIM master and clients:
To setup NIM Server:
# nim_master_setup -B -a device=/dev/cd0 -a file_system=/nim -a volume_group=nimvg
To setup NIM installation in a client:
# smitty nim_bosinst
To view the status of NIM installation in a NIM client:
# lsnim -l client_hostname
To define a lpp_source resource:
# nim -o define -t lpp_source -a source=/dev/cd0 -a server=master -a location=/nim/lpp_source/AIX_5_3_4 AIX_5_3_4
To define a spot resource:
# nim -o define -t spot -a server=master -a location=/export/nim/spot -a source=lpp_source530 spot530
To remove a resource:
# nim -o remove AIX_5_3_4
To initialize a NIM client for diag operation:
# nim -o diag client_hostname
To initialize a NIM client for maintenance operation:
# nim -o maint client_hostname
To unconfigure a NIM server:
# nim -o unconfig master_server
To allocate a SPOT to a NIM client:
# nim -o allocate -a spot=AIX_5_3 client_hostname
To deallocate a SPOT from a NIM client:
# nim -o deallocate -a spot=AIX_5_3 client_hostname
To remove a NIM client after deallocating all its resources:
# nim -o remove client_hostname
To reboot a client:
# nim -o reboot client_hostname
To list all the NIM resources:
# lsnim
To list detailed information about a nim client:
# lsnim -l client_hostname
To list the resources allocated to a NIM client:
# lsnim -c resources client_hostname
NIM
To list all the mksysb resources
# lsnim -t mksysb
# lsnim -t spot
To list all the machines
# lsnim -t standalone
OR
# lsnim -c machines
To reset the NIM status of system host-10
# nim -o reset -a force=yes host-10
or
# nim -Fo reset host10
To Force Deallocate all the resources from system host-01
# nim -Fo deallocate -a subclass=all host-01
To rebuild the /etc/niminfo file in the master
# nimconfig -r
To rebuild the /etc/niminof file in the NIM client
# niminit -a master=
To remove a machine from the NIM environment
# nim -o remove
To define a mksysb resource
# nim -o define -t mksysb -a server=master -a location=
To enable Base OS install in a client using mksysb resource
# nim -o bos_inst -a source=mksysb -a spot=spot_53ML4 -a accept_licenses=yes
-a mksysb=
To add additional software to lppsource1
# nim -o update -a packages=all source=/dev/cd0 lppsource1
To update the spot and lppsource to the latest level
# nim_update_all -l
Some useful NIM SMIT Fast paths
________________________________________
smit nim_mkmac # Adding new machines
smit nim_bosinst # For doing BOS install operation on a machine
Common NIM Error codes
________________________________________
608 - tftp retrieve of client info file failure
Action If a 608 hang is encountered, verify that the ClientName.info file exists in the /tftpboot directory. If it does not exist, retry the NIM operation to create it. If it does exist, verify that tftp access to the /tftpboot directory is not restricted in the /etc/tftpaccess.ctl file. is also possible that the network adapter was not configured properly in the boot environment
611 - Remote mount of NFS file system failure
Action 611 hangs occur when the client machine is unable to mount a resource from a server. Ensure that NFS is running on the resource server. Verify that the resources specified for the operation are exported properly by checking the /etc/exports and /etc/xtab files on the server. Also, confirm that the resources have permissions set correctly for reading.
613 - Failure setting up route tables
Action 613 hangs usually occur because a route is incorrectly defined for a network in the NIM database. Verify that the correct gateways are specified between networks, and all gateways are functional. Use debug-enabled network boot images to determine which routes could not be defined.
No comments:
Post a Comment